To jest tylko wersja do druku, aby zobaczyć pełną wersję tematu, kliknij TUTAJ
My Navia
Windows CE - forum użytkowników nawigacji GPS

Hardware - software - technikalia - HELP - TMC na urządzeniach Mio

xpac - 2016-11-09, 10:21

Witam, Odświeżę trochę temat. Posiadam MIO Spirit 7570LM ( podobna do 7200, 7500 ) uruchomiłem na niej Primo, chciałbym korzystać z TMC ale po wielu próbach jest jedna wielka kicha. Przeczytałem temat od deski do deski ( TMC na urządzeniach Mio również ). Odblokowałem port skryptem działa na com 1 szybkość 14400, kopiowałem różne konfiguracje TMC do pliku sys w priomo, testowałem różne wersje aplikacji, różne skiny, włączałem urządzenie z ładowarką i bez ( tam jest antena TMC), kopiowałem listę providerów do save, licencje mam wszystkie jakie są tylko dostępne. Stanęło na tym że Priomo szuka stacji ( zatrzymuje się dłużej na 85,7, 102.7, czasami się zawiesza), ale i tak nie znajduje sygnały TMC, nie wiem co jeszcze mógłbym przetestować, może jakieś rozsądne pomysły ?? dzięki za odpowiedź
jacekp1313 - 2016-11-09, 12:46

xpac napisał/a:
Odblokowałem port skryptem działa na com 1 szybkość 14400
To sa dane portu GPS. A na jakich parametrach działa Ci port TMC? Sprawdzałeś wg http://www.my-navia.pl/viewtopic.php?t=15573 punkt 38 ?

P.S. Przeniosłem z wątku "Igo Primo a TMC"

xpac - 2016-11-13, 15:16

jacekp1313 napisał/a:
xpac napisał/a:
Odblokowałem port skryptem działa na com 1 szybkość 14400
To sa dane portu GPS. A na jakich parametrach działa Ci port TMC? Sprawdzałeś wg http://www.my-navia.pl/viewtopic.php?t=15573 punkt 38 ?

P.S. Przeniosłem z wątku "Igo Primo a TMC"


[gps]
port=2
baud=4800
source = "nmea"

[tmc]
source="GNSPORT"
port="COM,1"
baud=14400
saved_config_available="1"
saved_config_classname="NMEA_GPSTMC_GNSPORT"
saved_config_port="1"
saved_config_portname="COM"

to są dane mojego urządzenia. Niestety po "zabawie" z odblokowaniem portu TMC, nie znajduje mi sygnału GPS mimo zmiany wartości w pliku system. Druga sprawa, po resecie urządzenia rejestr nie wraca do stanu pierwotnego, rozszerzenie mscr rozpoznawane jest teraz jako nieznany plik ( wcześniej było ok ). Jakieś pomysły ?? może rozładować urządzenie do końca ??

jacekp1313 - 2016-11-13, 20:03

Nie pytałem o wpisy w sys.txt
Napisz, którymi programami testowałes porty i jakie były wyniki/komunikaty

xpac - 2016-11-13, 22:14

jacekp1313 napisał/a:
Nie pytałem o wpisy w sys.txt
Napisz, którymi programami testowałes porty i jakie były wyniki/komunikaty


Podałem prawidłowe ustawienie portów GPS i TMC które powinny być w moim urządzeniu - na pewno są OK. Testowałem 3 programami które są w tym wątku
http://www.my-navia.pl/vi...p=320965#320965

ale tak naprawdę na żadnym nie znalazłem sygnału - wydawało mi się że żaden nie jest odpowiedni do tej wersji nawigacji/odbiornika tmc... tak jak pisałem wcześniej, odblokowałem port skryptem i testowałem programem. Ten trzeci TMC RoyalTek TMC Demo otwiera por ale i tak nie widzę żadnych rezultatów.

jacekp1313 - 2016-11-13, 22:22

xpac napisał/a:
Testowałem 3 programami które są w tym wątku http://www.my-navia.pl/vi...p=320965#320965 ale tak naprawdę na żadnym nie znalazłem sygnału
Wygląda na zablokowany port. Lub nie podłączona antena - używasz oryginalnego zasilacza samochodowego?
Jak uruchamiasz iGO (a raczej - jak zwalniasz port GPS)? Jakie procesy killujesz?

xpac - 2016-11-13, 23:38

jacekp1313 napisał/a:
xpac napisał/a:
Testowałem 3 programami które są w tym wątku http://www.my-navia.pl/vi...p=320965#320965 ale tak naprawdę na żadnym nie znalazłem sygnału
Wygląda na zablokowany port. Lub nie podłączona antena - używasz oryginalnego zasilacza samochodowego?
Jak uruchamiasz iGO (a raczej - jak zwalniasz port GPS)? Jakie procesy killujesz?


ładowarka oryginalna, testowałem na tym i igo coś tam pokazuje, fale typu 87.5, 102.7 ale cały czas zatrzymuje się na tych samych parametrach pokazując komunikat "brak sygnału TMC
Kill("AppStartupSec.exe")
sleep 1000
Notify = RegRead("HKLM", "Drivers\BuiltIn\SW_TMC", "Protocol" )
If ( Notify = 1)
EndIf
If ( Notify = 0)
RegWriteDWord HKLM, Drivers\BuiltIn\SW_TMC, Protocol, 1
Reset
EndIf

przy tej opcji

Kill("AppStartupSec.exe")
Kill("AppStartupPri.exe")
Kill("SmartST_CE.exe")
Run "\Storage Card\MioAutoRun\Programs\TroNik\PowerButton.exe"
sleep 1000
Notify = RegRead("HKLM", "Drivers\BuiltIn\SW_TMC", "Protocol" )
If ( Notify = 1)
Run "\Windows\Desktop\MioPocket.lnk"
EndIf
If ( Notify = 0)
RegWriteDWord HKLM, Drivers\BuiltIn\SW_TMC, Protocol, 1
Reset
EndIf

nawigacja cały czas się restartuje, igo nie pokazuje zakresu skanowania - "brak sygnału TMC". W chwili obecnej nawigacja wykrywa pliki mscr jako nieznane, przywrócę backup i zobaczę czy da radę zmienić rejestr.

jacekp1313 - 2016-11-14, 07:08

Na razie zapomnij o iGO i ćwicz wyłącznie na programach testujących porty. Inaczej nie będzie wiadomo, czy problem tkwi w iGO, czy zablokowanych portach.
Sprawdź jeszcze listę uruchomionych procesów - w niektórych Mio samo killowanie Appstartupsec nie wystarczało.

bartek2104 - 2017-10-31, 17:53

Witam jak uruchomić tmc na mio spirit 670?
jacekp1313 - 2017-10-31, 18:57

Tak, jak opisano w tym wątku.
emes125 napisał/a:
Moduł TMC jest do niej dedykowany i na pewno dobrze działa
xpac napisał/a:
ładowarka oryginalna
Cytat:
musisz podłączyć i antenę, i zasilanie. Przy dedykowanym uchwycie powinien zacząć przeszukiwać częstotliwości.

No i napisz, w jakim programie chcesz odbierać komunikaty

bartek2104 - 2017-10-31, 19:02

Muszę mieć jakas dodatkowa antenę do nawigacji ? Program igo Primo
jacekp1313 - 2017-10-31, 19:04

Musisz mieć dedykowany uchwyt z TMC do S 670 i oryginalną ładowarkę - na ogół kabel jest anteną.
Zacznij od odbioru TMC na fabrycznym MioMap.
Ale nie wszystkie Mio maja fabryczne TMC: https://eu.mio.com/pl_pl/TMC.htm#.Wfi7QIhFeUk
Wówczas musisz dobrać jakis odbiornik (sama antena nic Ci nie da) - na M500 miałem cos w tym stylu: http://www.stratec24.de/i...-cable:8463.jpg

bartek2104 - 2017-10-31, 19:48

Narazie nie mam jak sprawdzić na miomap czy działa tmc bo jestem w niemczech A mapę mam tam tylko na Polskę
jacekp1313 - 2017-10-31, 20:04

Od tego trzeba zacząć - albo opisanymi w tym wątku skryptami skillowac procesy blokujące port TMC i testowac programami opisanymi w http://www.my-navia.pl/viewtopic.php?t=15573 punkt 38


Powered by phpBB modified by Przemo © 2003 phpBB Group