To jest tylko wersja do druku, aby zobaczyć pełną wersję tematu, kliknij TUTAJ
My Navia
Windows CE - forum użytkowników nawigacji GPS

iGO, Primo Android - Primo (ANDROID) i TMC

thaus - 2013-06-27, 22:20

Dobra panowie a teraz cos gdzie sie juz dokopac nie potrafię nigdzie Igo na Andku plus TMC na zewnetrznym odbiorniku jak to ugryzsc ?
varth - 2013-06-27, 23:17

TMC w iGO na Androidzie działa tylko poprzez połączenie z internetem.
lupas1 - 2013-07-31, 21:28

witam wsiech
to moj 1szy post tu wiec niewiem moze juz ktos miał taki problem wiec prosze o pomoc
juz od wielu wersji wstecz i wielu miesiecy (od lutego) walcze z http-TMC, pokazuje mi tylko z innych krajow, tzn. z sasiedniej Anglii i z Irlandii Północnej, a mieszkam w Irlandii i nie mam TMC z tego kraju, chyba ze Irlandia nie przekazuje info o trafikach przez internet albo mam cos nie tak z licencjami, albo może jakiś specjalny wpis w sys.txt, prosiłbym o jakąś fachową porade bo nie mam juz pomysłów, a moze muszą byc wszystkie mapy np: cała zawartosc europy zachodniej, bo w Liscie zawartosci - Predefiniowana sieć dróg mam 4 pliki Europa Zachodnia ....... itd, a pod kazdym z nich na czerwono "Brak map (map/western_Europe_NQ_.......... .hnr), moze to jest przyczyna, ale dlaczgo w takim razie pokazuje mi traffiki/znaki z UK? Dodam jeszcze tylko że jak miałem Igo w tel. na windzie to RDS-TMC az hulało po europie zero problemów, uzywałem do tego zewn. odbiornik na Bluetooth Navilock GPS-TMC, a niestety ten odbiornik nie zadziała jako zewn RDS-TMC na Andka, chyba ze zna ktos jakis sposób.
wracając do tematu mam problem z HTTP-TMC i tak naprawde do tego sa ważne pliki licencji z IGO\licence, natomiast zawartosc z iGO8\content\tmc *.tmc do HTTP-TMC nie jest potrzebna, ponieważ trafiki idą inną drogą, czyli trafiają przez neta do tel, wiec musi byc włączony przesył danych, ale o dziwo mam w igo trafiki ale tylko z UK, i to mnie zastanawia co mam nie tak, czekam na jakąkolwiek pomoc w rozwiązaniu tego problemu :-? , tel: galaxy note 2, Android 4.1.2, jesli potrzeba wiecej szczegołów to pytać - dopisze, pozdrawiam wszystkich

lupas1 - 2013-07-31, 23:14

siemka piotrekcz
dzieki za szybki odzew,
skąd wiadomo ze dla ROI nie ma TMC-HTTP? bo nie zdazyłem sie jeszcze dokopać,
te osły zawsze wszystko muszą miec na koncu, jak juz swiat niczego nie chce,
normalnie jak za murzynami :mrgreen:
a moze jest jakis sposób zeby zewnetrzny RDS-TMC jakos zaprzegnąć do Andka?,
jak pisałem wyżej,
pozdrawiam

Arturek - 2013-10-31, 12:50

Witam
Mam prośbe do kolegów o pomoc w uruchomieniu TMC online na androidzie
Na "zwykłej" nawi mam działające normalne TMC. Natomiast teraz chciałem uruchomić TMC online na androidzie i mam problem
Mam Primo 2.0 (9.6.7.235654) na androida (z forum)
Czytałem o wpisach w SYS.TXT => tak wygląda mój
Kod:
[device]
type="android"

[rawdisplay]
driver=engine

[android]
fullscreen=0
tablet=0
has_physical_home_button=0

[feature]
back_button=1

[network]
available=1

[http]
enabled=1

[tmc-http]
enabled=1
start=1
servers.size=1
;servers[0].url="http://zippy.naviextras.com/services/tmclite/data/nng-igo-tmc-iphone/0/"
servers[0].url="http://zippy.naviextras.com/services/tmclite/data/nng-igo-tmc-russia/0/"

[naviextras]
boot_service_address="http://zippy.naviextras.com/services/index/rest/2/boot"

[interface]
extra_settings=1
capture_to_jpeg=1
ui_labs=1
save_checksum=0

[debug]
show_networkservices= 1
skip_eula=0
experimental_features=1
imei="000000000000000"
screenshotsavecameraini=0
screenshotfilename="\android_linked_root\capture\image_%02d.jpg"

[gps]
location_net=1
location_gps=1
accuracy_workaround=1
background_navigation=1

[tts]
always_say_road_names=1
skip_road_numbers=1
tts_buffer=131072
announce_exit_directions=1
tts_logics=3
priority="HIGH"
announce_street_name=1
skip_exit_numbers=0

[poi]
picturepoi_has_mypicturepoi=1
picturepoi_scan="/mnt/ext_card/Pictures"
 
[sound]
lua_voice_enabled=1
csv_voice_enabled=1

[3d_config]
disable_roadsign_navigation_mode=1

Eksperymenty robię w domu, a telefon przełączyłem w tryb wifi = po wi-fi łączy się z internetem
Sygnał GPS też łapie
Natomiast nie mogę złapać TMC online - domyslam się, że biblioteki DLL od windows nie przydadzą się w andridzie

Pytanie - co ew. dograć lub dopisać

pozdrawiam
Arturek

piotrekcz - 2013-10-31, 15:20

Arturek napisał/a:
nie mogę złapać TMC online

Kod:
[network]
available=1

[http]
enabled=1

[tmc.src.http]
enabled=1

[naviextras]
boot_service_address="http://zippy.naviextras.com/services/index/rest/2/boot"

[tmc-http]
start=1
enabled=1
servers.size=1
servers[0].url="http://zippy.naviextras.com/services/tmclite/data/nng-igo-tmc-iphone/0/"
servers[1].url="http://tmchttp0.naviextras.com/nng-igo-tmc/0/"
servers[2].url="http://tmchttp1.naviextras.com/nng-igo-tmc/0/"
servers[3].url="http://tmchttp2.naviextras.com/nng-igo-tmc/0/"
servers[4].url="http://tmchttp3.naviextras.com/nng-igo-tmc/0/"
servers[0].min_dt_refresh=10
servers[1].min_dt_refresh=10
servers[2].min_dt_refresh=10
servers[3].min_dt_refresh=10
servers[4].min_dt_refresh=10


Arturek napisał/a:
domyslam się, że biblioteki DLL od windows nie przydadzą się w andridzie

Nie są potrzebne.

Arturek - 2013-10-31, 20:19

Witam
Dzięki - działa
(sprawdzone na Sony Xperia J oraz Xperia L)

pozdrawiam
Arturek








piotrekcz - 2014-01-12, 11:44

Temat TMC via RDS na Androidzie, pojawia się na forum w rożnych miejscach. Ostatnio wymieniłem swoje spostrzeżenia z kolegą sliski4, musiałem jednak "odpuścić" z powodu braku możliwości przedstawienia "namacalnych" dowodów - dokładny opis urządzenia z odbiornikiem TMC. Czytając specyfikację techniczną urządzenia NavGear 5"-Navi mit Android "StreetMate GTA-50-3D" (Europa), znajdziemy taką informację:
Cytat:
TMC-Receiver

napisałem do firmy o podanie szczegółów technicznych tego odbiornika, jednak nie otrzymałem odpowiedzi. Jedna z ostatnich wersji programu iGO Primo 2.4 Isr free.... , zawiera plik devices w którym znajdziemy urządzenie E_Sense_Infiniti.ini, z taką sekcją TMC:
Kod:
[tmc]
internal_tmc_name="gnsport"
source="gnsport"
port="COM,3"
version=-1
tuner_model= "TMC_GPSTMC_TUNER"
auto_detour_calc=0
announce_total_route=1
tmcprovider_ignore_altfreq=1
tmcprovider_rssi_stability=0
tmcprovider_rssi_average=0
tmcprovider_tuner_scanlevel=1
tmcprovider_max_freeze_timeout=120
tuneralg_rds_packet_timeout = 3500
tuneralg_8a_packet_timeout=6500
tuneralg_last_8a_packet_timeout=30000
tuneralg_3a_packet_timeout=20000
check_ltn_support=1
tmclogic_hun = "1,1,150,0,2500:3500:5500:30000,0,150,150,1"
tmclogic_ger = "1,0,100,0,3500:8500:20000:60000,0,500,500,1"
tmclogic_aut = "1,0,100,0,3500:8500:20000:60000,0,300,300,1"
tmclogic_usa = "1,0,100,0,4500:8500:20000:60000,0,500,500,1"
tmclogic_can = "1,0,100,0,4500:8500:20000:60000,0,500,500,1"
tmclogic_bra = "0,1,600,0,2500:5500:8500:30000,0,600,600,1"
tmclogic_rus = "0,1,600,0,2500:5500:8500:30000,0,600,600,1"
tmclogic_sui = "1,0,100,0,5500:50000:55000:240000,0,300,300,1"
tmclogic_and = "1,0,100,0,3500:8500:20000:60000,0,150,150,1"
tmclogic_bel = "1,0,100,0,3500:8500:20000:60000,0,150,150,1"
tmclogic_bul = "1,0,100,0,3500:8500:20000:60000,0,200,200,1"
tmclogic_cro = "1,0,100,0,3500:8500:20000:60000,0,300,300,1"
tmclogic_cze = "1,0,100,0,3500:8500:20000:60000,0,150,150,1"
tmclogic_den = "1,0,100,0,3500:8500:20000:60000,0,200,200,1"
tmclogic_esp = "1,0,100,0,3500:8500:20000:60000,0,500,500,1"
tmclogic_fin = "1,0,100,0,3500:8500:20000:60000,0,300,300,1"
tmclogic_fra = "1,0,100,0,3500:8500:20000:60000,0,300,300,1"
tmclogic_gbr = "1,0,100,0,3500:8500:20000:60000,0,500,500,1"
tmclogic_gre = "1,0,100,0,3500:8500:20000:60000,0,300,300,1"
tmclogic_ita = "1,0,100,0,3500:8500:20000:60000,0,500,500,1"
tmclogic_lux = "1,0,100,0,3500:8500:20000:60000,0,150,150,1"
tmclogic_ned = "1,0,100,0,3500:8500:20000:60000,0,300,300,1"
tmclogic_nor = "1,0,100,0,3500:8500:20000:60000,0,300,300,1"
tmclogic_pol = "1,0,100,0,3500:8500:20000:60000,0,150,150,1"
tmclogic_slo = "1,0,100,0,3500:8500:20000:60000,0,300,300,1"

prawdopodobnie jest to wbudowana stacja multimedialna. Infiniti skojarzyłem z marką samochodu, nie znalazłem jednak żadnych konkretnych informacji na stronie producenta.
Urządzenia typu smartfony \ tablety, nie mają czegoś takiego jak "port" nie wiem, jak można w takim przypadku podłączyć np. zew. odbiornik i przesłać sygnał, ale....
Można podłączyć (np. tablet bez GPS) zew. odbiornik GPS - http://www.gns-gmbh.com/index.php?id=157&L=1 , dlaczego więc w niedalekiej przyszłości nie byłoby możliwe podłączenie zew. odbiornika TMC - jeśli taki zostanie zaprojektowany.

ogerard - 2014-01-12, 11:53

Arturek napisał/a:
Witam
Dzięki - działa

pozdrawiam
Arturek


A jaki typ komunikatów wam pokazuje ? Bo ja mam tylko 'związane z płynnością' brak robót drogowych i zamkniętych odcinków. Co skutkuje np. wyznaczaniem trasy po nieistniejących pasach w W-wie (zburzone przęsła mostu Grota w związku z jego remontem).

ogerard - 2014-01-12, 12:38

Przez most można (ruch odbywa się jedną stroną mostu) ale zaraz za nim są na mapie zjazdy które na razie nie istnieją - zostały wyburzone. Wjazd na most od ul.Modlińskiej także został zburzony, a według iGo i HD Traffica można się nim poruszac.

Jedynie AM Traffic pokazywał iż jazda odbywa się jedną skrają mostu.

lgreg - 2014-03-29, 09:42

Witam,
jaki wpis w sys.txt jest najbardziej prawidłowy by igo na androida pobierało komunikaty. Obecnie działa to na mim tablecie bardzo cienko, komunikaty pobierane są bardzo rzadko, w większości nie ma żadnych. Czasami pomaga reset całego tableta, czasami samo zaczyna działać. Używam areo2 w tablecie - może to przez to ? - chociaż strony internetowe otwierają się bez problemu więc jest połączenie a nie wiem czemu nie ciągnie komuników. Jaki powinien być najbardziej prawidłowy wpis sys.txt by TMC online działo prawidłowo?

MiroIng - 2014-03-30, 15:40

koledzy, pytanie dotyczące konfiguracji. TMC nie działa przez 3 G, tylko przez wifi w domu. Tel. sony xperia j - może w telefonie mam coś wyłączone, czy brakuje coś w programie... Nie wiem gdzie szukać...
Arturek - 2014-03-31, 22:12

MiroIng napisał/a:
koledzy, pytanie dotyczące konfiguracji. TMC nie działa przez 3 G, tylko przez wifi w domu. Tel. sony xperia j - może w telefonie mam coś wyłączone, czy brakuje coś w programie... Nie wiem gdzie szukać...


Witam

1) sprawdź w telefonie
- ustawienia
- uzycie danych
- komórkowa transmisja danych => włącz

2) Czy internet działa w Twoim telefonie poprzez 3G / GSM ?
Może nie masz wykupionego pakietu dostępu do internetu?

3)
geranium napisał/a:
zainstaluj sobie skin Dimka jest tam możliwość wyboru ściągania danych po wifi lub 3g

a dane komórkowe masz włączone? bo program radzi sobie znakomicie bez WiFI!


Nawet bez skina, w ustawieniach programu jest opcja "zarządzaj przepustowością" => może ta opcja jest włączona i są ustawione limity przesyłanych danych

pozdrawiam
Arturek

MiroIng - 2014-04-01, 07:53

Dzięki koledzy za pomoc, już jest ok. Nie miałem skonfigurowanego internetu w telefonie, oraz wyłączony transfer danych. Pytanie jeszcze co do wyświetlania zdarzeń:
mam primo israel i to chyba problem po stronie programu że nie pokazują się zdarzenia zaraz po wejściu w ikonę. Wszystkie zdarzenia 0 z 0. Dopiero po wejściu dalej widoczne są komunikaty.
2ga sprawa to różnice pomiędzy TMC z RMF-u a komunikatami on-line. W tym pierwszym występuje np. zamknięta ulica Warszawska - Rzeszów. Natomiast w komunikatach on-line nie ma nic na ten temat... Zastanawiam się czy byłaby możliwość pobierać dane z jakiegoś "lokalnego" serwera, tak by były one bardziej dokładne...

ebenista - 2014-09-24, 20:42

witam
mam problem z TMC online , mianowicie od jakiegoś czasu przestało działać
wcześniej działało prawidłowo , pobierało wszystkie zdarzenia z internetu
telefon ma połączenie z internetem
moje iGO to wersja iGO_Turkey_v.9.6.29.356072_ Full Rez
i skin diMkaWA_aP114_24
kilka razy odinstalowywałem iGO i nic dalej to samo
instalowałem inne wersje i tez brak komunikatów
według mnie to chyba coś się popierdzieliło w telefonie Galaxy Xcover 2
ale co ?
macie może jakieś pomysły



Powered by phpBB modified by Przemo © 2003 phpBB Group