To jest tylko wersja do druku, aby zobaczyć pełną wersję tematu, kliknij TUTAJ
My Navia
Windows CE - forum użytkowników nawigacji GPS

3584, 438xxx, 4330xx, 4390 - 4330A instalacja programu .cab

wojtassslg - 2014-02-06, 09:18
Temat postu: 4330A instalacja programu .cab
Witam serdecznie
potrzebuje zainstalować na nawigację program z rozszerzeniem .cab instaluję program ok 9,5 MB przez przewód na karcie pamięci nawigacji za pomocą Active Sync 4.5 oraz WinCE CAB Installer na XP.
Podczas instalacji pojawia się program w oknie nawigacja, natomiast po zakończeniu instalacji program samoistnie się usuwa. Navi na standardowym GPSshell.ini

Co jeszcze trzeba ogarnąć aby instalacja się powiodła? Domniemam, że jakieś zabezpieczenie na nawigacji powoduje taką kolej rzeczy.

jestem_ktoś - 2014-02-06, 09:41

Znika zaraz po zainstalowaniu, czy po resecie?

Więcej: http://www.my-navia.pl/viewtopic.php?t=15573 p.39

wojtassslg - 2014-02-06, 17:48

Usuwa się samoistnie po dojściu paska instalacyjnego do końca. Instalacja na urządzeniu i zwiększeniu pamięci do 15MB nic nie pomaga...
jacekp1313 - 2014-02-06, 18:18

Nawi nie mają żadnych zabezpieczeń. Być może program nie pasuje do wersji Windowsa CE.
A co to jest za soft?

wojtassslg - 2014-02-06, 19:01

Nawigacja WinCE 5.0 program to FESmobile 2.2 .cab http://www.multiecuscan.net/
nagranie przez MSCEInf na SD i otwarcie .exe wyskakuje błąd.
Czy jest możliwość rzucenia mi linku do instalaci .cab który na tej navi działa?
Była by możliwość wyeliminowania hipotezy o zabezpieczeniach, których podobno niema i mogło by to potwierdzić że FESmobile nie działą na WindowsCE
pozdrawiam

jestem_ktoś - 2014-02-06, 19:30

Problem w tym, że WinCE na nawigacjach to nie system, tylko kupa zebranych do kupy procedur pod potrzeby konkretnego procesora i programu nawigacyjnego i może na innym urządzeniu pieknie da sie zainstalować.

CAB-y zawsze były kłopotliwe - jak widać ze wskazanego wątku

wojtassslg - 2014-02-07, 15:19

Rozumiem, ważna wiedza. Niemniej jednak będę bardzo wdzięczny za podrzucenie linku do programu/aplikacji .cab, która była testowana na winCE 5.0 a najlepiej jeszcze na tym urządzeniu. Pozwoli to weliminować wiele spekulacji.
Z góry serdecznie dziekuję.

jacekp1313 - 2014-02-07, 20:20

wojtassslg napisał/a:
MSCEInf na SD i otwarcie .exe wyskakuje błąd
A jaki?
Chyba to nie sprawa CAB-a, a bardziej niezgodności programu z systemem...

Co do testów: spróbuj na przykład tego: http://chomikuj.pl/jajace...,3565415932.zip
Kiedyś miałem ten model i chyba mi działały

wojtassslg - 2014-02-09, 10:23

Pisze, że brakuje jakiegoś pliku itd itd, wygląda na to, że aplikacja nieprzystosowana do Windows CE. Napisałem do producenta oprogramowania którego mam wykupiona licencję i zobaczymy co odpisze. .caby z linku działają dziękuje za pomoc :)
jacekp1313 - 2014-02-09, 18:49

wojtassslg napisał/a:
że brakuje jakiegoś pliku itd itd,
A konkrety? Często wystarczy dograć brakującą dll-kę
wojtassslg - 2014-02-09, 22:40

Cannot find 'FESmobile' (or one of its components). Make sure the path and filename are correct and that all the required libraries are available.
jacekp1313 - 2014-02-10, 07:14

Zacznij od dogrania brakujących bibliotek - szczegóły w wątku dll http://www.my-navia.pl/viewtopic.php?t=3998
wojtassslg - 2014-02-11, 17:02

Czy mogę prosić o wskazanie które biblioteki gdzie mają być wrzucone/zainstalowane przez jaki program? Ten wątek to jeden wielki śmietnik wg. mnie bo połowa linków do downloadu nie istnieje zapewne od wieków. Tematów w tym wątku jest od groma, nie rozumiem zupełnie co tam się dzieje.
jacekp1313 - 2014-02-11, 17:49

Na początku wątku jest taki fragment
Cytat:
Jak szybko i łatwo znaleźć brakujące biblioteki
Od razu gwoli wyjaśnienia: sposób ten znalazłem na angielskim forum poświęconym GPS.
Ściągamy program stąd...
W tym samym poście cały opis postępowania
wojtassslg - 2014-02-11, 22:02

Dziękuje za podpowiedzi, zrobiłem tak jak w poście było napisane. Po uruchomieniu na SD nawigacji komunikat "'DEPENDS' is not a valid Windows CE application." następnie sru na PC i po otwarciu takie rzeczy jak w załącznikach, niestety .jpg o wadze 65kb i 132 nie chca sie załadować i krzyczy mi ze za duży rozmiar wiec musze napisać ze czerwony kolor był tylko po otwarciu DEPENDS.CHM


Powered by phpBB modified by Przemo © 2003 phpBB Group